using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*\/d\/([a-zA-Z]*)\/.*\/(\d+_\d+\.mp4).*";
string input = @"var a = 776644%94536;
document.getElementById('dlbutton').href = ""/d/lHCIDyYJ/""+a+""/2842_4.mp4"";
if (document.getElementById('fimage')) {
document.getElementById('fimage').href = ""/i/lHCIDyYJ/""+a+""/2842_4.mp4"";
}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}