Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
r"
(#+)
"
mg
Test String
New
### Start of program number = 0 ## Initialize the variable number += 1 # Increment the variable
Substitution
Processing...
\/\/