$re = '/TOTAL\s+>(\d{1,3}(?:\.\d{3})*,\d{2})\s+DEDU.*?ES/m';
$str = 'NOME: TESTE DE SILVA SAURO
CPF: 785.981.970-84
IMPOSTO SOBRE A RENDA - PESSOA FÍSICA
DECLARAÇÃO DE AJUSTE ANUAL
EXERCICIO 2018 ANO-CALENDÁRIO 2017
TOTAL
>62.715,90
DEDUÇÕES
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);