#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\s{10}Глава "
Local $sString = "<?php" & @CRLF & _
"$blocks = [" & @CRLF & _
" 'ревочной лестницы — небось скрючило бы в три погибели! Не скоро запросил бы еды, я — то уж знаю!" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" Нат не стал смотреть, как мы клали заколдованный пирог Джиму в миску, а в самый низ, под провизию, мы сунули три жестяные тарелки, и Джим все это получил в полном порядке; а как только остался один, разломал пирог и спрятал веревочную лестницу к себе в тюфяк, а потом нацарапал какие-то каракули на тарелке и выбросил ее в окно." & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" Глава тридцать восьмая" & @CRLF & _
" “ЗДЕСЬ РАЗОРВАЛОСЬ СЕРДЦЕ УЗНИКА”" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" Делать эти самые перья было сущее мученье'," & @CRLF & _
" 'ете, голубчик? Испеките, да я вам за это что угодно — в ножки поклонюсь, вот как!" & @CRLF & _
" — Ладно уж, испеку, раз это для тебя: ты ведь к нам хорошо относился, беглого негра нам показал. Только уж смотри будь поосторожней. Когда мы придем, ты повернись к нам спиной, и боже тебя упаси глядеть, что мы будем класть в миску! И когда Джим будет вынимать пирог, тоже не гляди — мало ли что может случиться, я почем знаю! А главное, не трогай ничего заколдованного." & @CRLF & _
" — Не трогать? Да господь с вами, мистер Сид! Я и пальцем ни до чего не дотронусь, хоть озолоти меня!" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" Глава тридцать седьмая" & @CRLF & _
" ДЖИМ ПОЛУЧАЕТ ВОЛШЕБНЫЙ ПИРОГ" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" Это дело мы уладили; потом пошли на задний двор, к мусорной куче, где валялись старые сапоги, тряпки, битые бутылки, дырявые кастрюльки и прочий хлам, покопались в нем и разыскали старый жестяной таз, заткнули получше дырки, чтобы испечь в нем пирог, спустились в погреб и насыпали полный таз муки, а оттуда пошли завтракать. По дороге нам попалось два обойных гвоздя, и Том сказал, что они пригодятся узнику — выцарапать ими на стене темницы свое имя и свои злоключения; один гвоздь мы'" & @CRLF & _
" ];"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")