$re = '/\s{10}Глава /m';
$str = '<?php
$blocks = [
\'ревочной лестницы — небось скрючило бы в три погибели! Не скоро запросил бы еды, я — то уж знаю!
Нат не стал смотреть, как мы клали заколдованный пирог Джиму в миску, а в самый низ, под провизию, мы сунули три жестяные тарелки, и Джим все это получил в полном порядке; а как только остался один, разломал пирог и спрятал веревочную лестницу к себе в тюфяк, а потом нацарапал какие-то каракули на тарелке и выбросил ее в окно.
Глава тридцать восьмая
“ЗДЕСЬ РАЗОРВАЛОСЬ СЕРДЦЕ УЗНИКА”
Делать эти самые перья было сущее мученье\',
\'ете, голубчик? Испеките, да я вам за это что угодно — в ножки поклонюсь, вот как!
— Ладно уж, испеку, раз это для тебя: ты ведь к нам хорошо относился, беглого негра нам показал. Только уж смотри будь поосторожней. Когда мы придем, ты повернись к нам спиной, и боже тебя упаси глядеть, что мы будем класть в миску! И когда Джим будет вынимать пирог, тоже не гляди — мало ли что может случиться, я почем знаю! А главное, не трогай ничего заколдованного.
— Не трогать? Да господь с вами, мистер Сид! Я и пальцем ни до чего не дотронусь, хоть озолоти меня!
Глава тридцать седьмая
ДЖИМ ПОЛУЧАЕТ ВОЛШЕБНЫЙ ПИРОГ
Это дело мы уладили; потом пошли на задний двор, к мусорной куче, где валялись старые сапоги, тряпки, битые бутылки, дырявые кастрюльки и прочий хлам, покопались в нем и разыскали старый жестяной таз, заткнули получше дырки, чтобы испечь в нем пирог, спустились в погреб и насыпали полный таз муки, а оттуда пошли завтракать. По дороге нам попалось два обойных гвоздя, и Том сказал, что они пригодятся узнику — выцарапать ими на стене темницы свое имя и свои злоключения; один гвоздь мы\'
];';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);