using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d{4}[A-Za-z]{2}$";
string input = @"Valid from
Zipcode from
0000AA
1798AA
8900AA
9167aa
Valid from
Zipcode to
1797zz
8899ZZ
9166ZZ
9999ZZ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}