// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d{4}[A-Za-z]{2}$").unwrap();
let string = "Valid from
Zipcode from
0000AA
1798AA
8900AA
9167aa
Valid from
Zipcode to
1797zz
8899ZZ
9166ZZ
9999ZZ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}