$re = '/<ul>([\s\S]+(?!<ul>))<\/ul>/mi';
$str = '<ul>
<li>a</li>
</ul>
test
<ul>
<li>b</li>
</ul>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);