# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?<serialCode>[a-zA-Z0-9]{3})(?:(?<serialMarket>[a-zA-Z]{1,2})(?<serialSuffix>[a-zA-Z0-9]*))?"
test_str = ("abcfobar\n"
"abc33bar\n"
"abca3bar\n"
"abc3abar\n\n"
"ab3abar\n"
"c3abar\n"
"3abar\n"
"bar\n\n"
"ab3a3ar\n"
"c3ab4r\n"
"3aba4\n"
"bar\n\n"
"234f22fsdf\n\n\n"
"a23a3ar\n"
"c3ab4r\n"
"3aba4\n"
"bar")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.