// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(<p>)(.[^<\/p>]*)(<\/p>)").unwrap();
let string = "<table><tr><td> <p>Text 1</p></td> </tr> <tr><td> <p>Text 2</p></td> </tr> <tr><td> <p>Text 3</p></td> </tr> </tr> </table>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}