package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*(?:\+?(\d{1,3})\s*)?(\s?\(?\d{2}\)\s?)?(\s?[-. (]*(\d{3})[-. )]*)?((\d{3,4})[-. ]*(\d{2,5})(?:[-.x ]*(\d+))?)\s*$`)
var str = `011 1 703 111 1234`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}