// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<ident>-?[a-zA-Z_][a-zA-Z0-9_-]+)\:|(?<value>[\S]+\;?)").unwrap();
let string = " border: 1px solid
#cecfd5
border-radius: 6px7
grid-template:
\"a a a\" 40px
\"b c c\" 40px
\"b c c\" 40px / 1fr 1fr 1fr;
color: green;";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}