$re = '/^(?:(?!.*b)(?<pre1>.*)|(?<pre2>.*)(b(?!c))(?<post>.*))$/m';
$str = 'abcd
abd
ad';
$subst = "$<pre1>$<pre2>$<post>bc";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;