import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
    public static void main(String[] args) {
        final String regex = "^(((?:\\+|00)964)|(0)*)7\\d{9}$";
        final String string = "7701234567\n"
	 + "770123456\n"
	 + "77012345678\n\n"
	 + "07701234567\n"
	 + "0770123456\n"
	 + "077012345678\n\n"
	 + "+9647701234567\n"
	 + "+964770123456\n"
	 + "+96477012345678\n\n"
	 + "009647701234567\n"
	 + "00964770123456\n"
	 + "0096477012345678\n\n"
	 + "738479299372492\n"
	 + "0770 123 4567";
        
        final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
        final Matcher matcher = pattern.matcher(string);
        
        while (matcher.find()) {
            System.out.println("Full match: " + matcher.group(0));
            
            for (int i = 1; i <= matcher.groupCount(); i++) {
                System.out.println("Group " + i + ": " + matcher.group(i));
            }
        }
    }
}