# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(((?:\+|00)964)|(0)*)7\d{9}$"
test_str = ("7701234567\n"
"770123456\n"
"77012345678\n\n"
"07701234567\n"
"0770123456\n"
"077012345678\n\n"
"+9647701234567\n"
"+964770123456\n"
"+96477012345678\n\n"
"009647701234567\n"
"00964770123456\n"
"0096477012345678\n\n"
"738479299372492\n"
"0770 123 4567")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.