import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!\\s*\"name\":.*).*\\n?|^\\s*";
final String string = "{\n"
+ " \"country_codes\": [\n"
+ " \"GB\"\n"
+ " ],\n"
+ " \"institution_id\": \"ins_118309\",\n"
+ " \"name\": \"Barclaycard (UK) - Online Banking: Personal\", // I want to extract this line only\n"
+ " \"oauth\": true,\n"
+ " \"products\": [\n"
+ " \"assets\",\n"
+ " \"auth\",\n"
+ " \"balance\",\n"
+ " \"transactions\",\n"
+ " \"identity\",\n"
+ " \"standing_orders\"\n"
+ " ],\n"
+ " \"routing_numbers\": []\n"
+ " },\n"
+ " \"institution_id\": \"ins_118309\",\n"
+ " \"name\": \"Metro Bank - Commercial and Business Online Plus\",\n"
+ " \"oauth\": true,\n"
+ " \"products\": [\n"
+ " \"assets\",\n"
+ " \"auth\",\n"
+ " \"balance\",\n"
+ " \"transactions\",\n"
+ " \"identity\",\n"
+ " \"standing_orders\"\n"
+ " ],\n"
+ " \"routing_numbers\": []\n"
+ " }";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}