# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!\s*\"name\":.*).*\n?|^\s*"
test_str = ("{\n"
" \"country_codes\": [\n"
" \"GB\"\n"
" ],\n"
" \"institution_id\": \"ins_118309\",\n"
" \"name\": \"Barclaycard (UK) - Online Banking: Personal\", // I want to extract this line only\n"
" \"oauth\": true,\n"
" \"products\": [\n"
" \"assets\",\n"
" \"auth\",\n"
" \"balance\",\n"
" \"transactions\",\n"
" \"identity\",\n"
" \"standing_orders\"\n"
" ],\n"
" \"routing_numbers\": []\n"
" },\n"
" \"institution_id\": \"ins_118309\",\n"
" \"name\": \"Metro Bank - Commercial and Business Online Plus\",\n"
" \"oauth\": true,\n"
" \"products\": [\n"
" \"assets\",\n"
" \"auth\",\n"
" \"balance\",\n"
" \"transactions\",\n"
" \"identity\",\n"
" \"standing_orders\"\n"
" ],\n"
" \"routing_numbers\": []\n"
" }")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.