import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?= *)([0-9.]+) *(\\w+) *(\\w+) *(\\w+) (\\w+) (.*)\\n";
final String string = " 0.000987 4 1547 Rx D 8 34 23 16 0 232 3 0 0\n"
+ " 0.006485 2 18FEF200x Rx d 8 00 00 FF FA FF FF FF FF Length = 571789 BitCount = 147 ID = 419361280x";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}