use strict;
my $str = ' 0.000987 4 1547 Rx D 8 34 23 16 0 232 3 0 0
0.006485 2 18FEF200x Rx d 8 00 00 FF FA FF FF FF FF Length = 571789 BitCount = 147 ID = 419361280x';
my $regex = qr/(?= *)([0-9.]+) *(\w+) *(\w+) *(\w+) (\w+) (.*)\n/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}