$re = '/^([\+\(\)\-0-9 ]*)([A-Za-z\' ]*)$/';
$str = '123-456-7890 Betty\'s cell
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);