#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)!\[(.*?)\]\(((?!http)\/?[^\s]+\.(png|jpg))\)"
Local $sString = "" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
".png)" & @CRLF & _
"" & @CRLF & _
"/" & @CRLF & _
"(?:!\[(.*?)\]\((.*?)\))" & @CRLF & _
"/" & @CRLF & _
"gm" & @CRLF & _
"" & @CRLF & _
"!\[.*\]\((?!http)[^\)]+\)" & @CRLF & _
"" & @CRLF & _
"(?:!\[(.*?)\]\((?!http)[^\)]\))"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")