using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\babc(\d+)_def((?!\1)\d{1,2})\b";
string input = @"abc1_def23
abc10_def99
but does not match for:
abc9_def9
abc9_def99
abc9_def123";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}