// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.{5}$").unwrap();
let string = "--- NFC (o \"á\" é representado como um único code point: U+00E1)
sabiá
--- NFD (o \"á\" é representado como dois code points: U+0061 U+0301)
sabiá";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}