package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?im)^([a-z0-9\-.]+\.[a-z0-9\-]+:?[0-9]*)?/?(.+)$`)
var str = `gitea/gitea:1.13.7
kiwigrid/k8s-sidecar:0.1.209
registry1.dso.mil/ironbank/opensource/docker/registry-v2:2.7.1
registry.opensource.zalan.do/acid/logical-backup:v1.7.0
docker.io/dpage/pgadmin4:5.5
registry1.dso.mil/ironbank/opensource/minio/minio:RELEASE.2021-08-31T05-46-54Z
ghcr.io/stefanprodan/podinfo:6.0.0
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}