re = /^(?=[^\d\n]*\d)(?=[^!-\/:-@[-`{-~\n]*[!-\/:-@[-`{-~]).*/m
str = 'abc-
_=-!@#
123-
a1c-'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end