import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\+?\\d?\\s*\\(?\\d{3}\\)?\\s*\\d{3}-\\d{2}-\\d{2}";
final String string = "\" заказать звонок\n\n"
+ " +7 499 399-57-07\n\n"
+ " +7 499 347-57-07\n\n"
+ " 01VVK@BK.RU\n\n"
+ "ПН-ЧТ 9.00-18.00 ПТ-ПТ 9.00-17.00\n\n"
+ "Моя корзина\n"
+ "↓\n"
+ "0\n"
+ "Список пожеланий\n"
+ "↓\n"
+ " Сравнение 0\n"
+ " \n"
+ " Закладки 0\n"
+ " \n"
+ " Корзина 0 Ваша корзина пуста\n"
+ " \n"
+ "Оформить заказ\n"
+ "КАТАЛОГ\n"
+ "АРЕНДА\n"
+ "О МАГАЗИНЕ\n"
+ "ОПЛАТА И ДОСТАВКА\n"
+ "ПРАЙСЫ\n"
+ "КОНТАКТЫ\n\n"
+ " +7 499 399-57-07\n\n"
+ "ИНТЕРНЕТ-МАГАЗИН ЛЕСТНИЦ И СТРЕМЯНОК \"МИР СТРЕМЯНОК\"\n\n"
+ "Интернет-магазин \"Мир Стремянок.ру\" предлагает вашему вниманию качественные лестницы-стремянки, вышки туры и подмости, выполненные из современных безопасных материалов и доступные для покупки в Москве по максимально выгодным ценам!\n\n"
+ "Мы предлагаем качественное оборудование для строительных и ремонтных работ, которое является залогом отменно выполненной поставленной задачи, безопасности строителей, а также существенной экономии времени. Благодаря бытовым и профессиональным алюминиевым лестницам, стремянкам, подмости и вышкам турам от лучших иностранных производителей вы забудете о поломках инструмента, коррозии материала или неудобствах.\n\n"
+ "СТРЕМЯНКИ\n"
+ " \n"
+ "ЛЕСТНИЦЫ\n"
+ " \n"
+ "ПОДСТАВКИ\n"
+ " \n"
+ "ВЫШКИ ТУРЫ\n\n\n"
+ "ПОДМОСТИ\n"
+ " \n"
+ "ДЕРЕВЯННЫЕ СТРЕМЯНКИ\n"
+ " \n"
+ "ШАРНИРНЫЕ\n"
+ "ЛЕСТНИЦЫ\n"
+ " \n"
+ "СПЕЦИАЛЬНЫЕ\n"
+ "ЛЕСТНИЦЫ\n\n\n"
+ "ЛЕСТНИЦЫ\n"
+ "С ПЛАТФОРМОЙ\n"
+ " \n"
+ "ЯЩИКИ И КЕЙСЫ\n"
+ " \n"
+ "АКСЕССУАРЫ\n"
+ " \n"
+ "КОЛЕСА И РОЛИКИ\n\n"
+ "УДОБНАЯ СИСТЕМА ВОЗВРАТОВ ТОВАРА\n"
+ "БЫСТРАЯ ДОСТАВКА ПО ВСЕЙ РОССИИ\n"
+ "СПЕЦПРЕДЛОЖЕНИЯХИТЫ ПРОДАЖНОВИНКИ\n\n"
+ "СТРЕМЯНКА ALTREX DOUBLE DECKER, 5 СТУПЕНЕЙ\n"
+ "9650 руб.\n"
+ " купить \n"
+ "ПРОФЕССИОНАЛЬНАЯ ЧЕТЫРЕХСЕКЦИОННАЯ ШАРНИРНАЯ ЛЕСТНИЦА 4Х4 KRAUSE STABILO\n"
+ "19400 руб.\n"
+ " купить \n"
+ "ДЕРЕВЯННАЯ СТРЕМЯНКА-ХОДУЛЯ БАЛЧУГ 2Х5 LINE (АРТ.2515L)\n"
+ "3900 руб.\n"
+ " купить \n\n"
+ "ПРЕИМУЩЕСТВА РАБОТЫ С НАМИ\n\n\n"
+ "Большой ассортимент товаров\n\n"
+ "В каталоге интернет-магазина представлено более 1000 наименований лестниц и стремянок различных групп назначения.\n\n"
+ " \n\n\n"
+ "Доступные\n"
+ "цены\n\n"
+ "Прямые поставки от производителей помогают минимизировать торговую наценку.\n\n"
+ " \n\n\n"
+ "Отменное качество продукции\n\n"
+ "Все реализуемые товары имеют соответствующие сертификаты качества, полученные производителями.\n\n"
+ " \n\n\n"
+ "Персональный\n"
+ "подход\n\n"
+ "Наши специалисты помогут подобрать лестницу стремянку для ваших нужд.\n\n"
+ "\"Мир Стремянок.ру\" – это место, где вы можете купить недорогую лестницу, стремянку. В интернет-магазине создан максимально удобный интерфейс, который без труда поможет вам сориентироваться в большом разнообразии представленных товаров. Совершить покупки, не выходя их своего офиса или дома, стало намного проще. Достаточно воспользоваться каталогом, представленным на сайте.\n\n"
+ "Каталог включает в себя сертифицированные товары, которые всегда есть в наличии. В ассортименте представлены лестницы и стремянки от зарубежных и отечественных производителей. Благодаря прямым поставкам и налаженной работе с поставщиками нашу продукцию отличает высокое качество и невысокая цена без накруток.\n\n"
+ "Ознакомиться с точными характеристиками и особенностями изделий вы можете на странице с товаром. Такие параметры, как высота, количество ступеней, вес лестницы, стремянки, предельная нагрузка в обязательном порядке указаны в описании товара.\n\n"
+ "Интернет-магазин \"Мир Стремянок.ру\" предлагает дешево приобрести легкие и прочные алюминиевые лестницы, и стремянки, а также изделия из дерева и других материалов, которые обладают высокой износостойкостью и рассчитаны на длительную эксплуатацию как в домашних условиях, так и на производстве, в строительстве. Здесь вы можете подобрать стремянку для библиотеки или домашнего использования, которая великолепно дополнит интерьер помещения. Среди представленных товаров без труда найдутся длинные лестницы и маленькие компактные стремянки-ступеньки.\n\n"
+ "Стремянки, лестницы и подмости промышленного назначения обладают разными техническими характеристиками, вы без труда сможете выбрать именно то изделие, которое максимально подойдет для вашей деятельности.\n\n\n\n"
+ "Покупка лестницы или стремянки, как правило, совершается с учетом многих параметров. Так, необходимо понимать, где и с какой целью будет использоваться приобретаемая лестница или стремянка; нагрузку, которая будет приходиться на покупаемое изделие. Если у вас возникли вопросы или затруднения с выбором, вы можете обратиться к нашим специалистам, позвонив по указанным на сайте телефонам.\n\n"
+ "Мы работаем с покупателями из Москвы и по всей территории России. Стоимость доставки зависит от выбора транспортной компании и удаленности заказчика от нашего магазина. Вы получите свой товар в максимально короткие сроки.\n\n"
+ "Если вам необходима консультация по какому-либо товару или помощь в выборе продукции – обращайтесь по контактным данным у нас сайте и наш менеджер предоставит квалифицированную помощью и исчерпывающую информацию по любому вопросу!\n\n"
+ "КАТАЛОГ\n\n"
+ "СТРЕМЯНКИ\n"
+ " \n"
+ "ЛЕСТНИЦЫ\n"
+ " \n"
+ "ПОДСТАВКИ\n"
+ " \n"
+ "ВЫШКИ ТУРЫ\n"
+ " \n"
+ "ПОДМОСТИ\n"
+ " \n"
+ "ШАРНИРНЫЕ ЛЕСТНИЦЫ\n"
+ " \n"
+ "СПЕЦИАЛЬНЫЕ ЛЕСТНИЦЫ\n"
+ " \n"
+ "ЛЕСТНИЦЫ С ПЛАТФОРМОЙ\n"
+ " \n"
+ "ЯЩИКИ И КОНТЕЙНЕРЫ\n"
+ " \n"
+ "АКСЕССУАРЫ\n"
+ " \n"
+ "КОЛЕСА И РОЛИКИ\n"
+ " \n"
+ "Товары месяца\n"
+ "ВЫШКА ТУРА ALTREX MITOWER (6.20)\n"
+ "195000 руб.\n"
+ "ДЕРЕВЯННАЯ СТРЕМЯНКА-ХОДУЛЯ БАЛЧУГ 2Х5 LINE (АРТ.2515L)\n"
+ "3900 руб.\n"
+ "SOLIDY СВОБОДНОСТОЯЩАЯ АЛЮМИНИЕВАЯ СТРЕМЯНКА 5 СТУП.\n"
+ "3370 руб.\n"
+ "ВЫШКА ТУРА ALTREX MITOWER (6.20)\n"
+ "195000 руб.\n"
+ "ДЕРЕВЯННАЯ СТРЕМЯНКА-ХОДУЛЯ БАЛЧУГ 2Х5 LINE (АРТ.2515L)\n"
+ "3900 руб.\n"
+ "SOLIDY СВОБОДНОСТОЯЩАЯ АЛЮМИНИЕВАЯ СТРЕМЯНКА 5 СТУП.\n"
+ "3370 руб.\n"
+ "ВЫШКА ТУРА ALTREX MITOWER (6.20)\n"
+ "195000 руб.\n"
+ "Клиенту\n"
+ "КАК ОТРЕМОНТИРОВАТЬ СТУПЕНЬКИ У СТРЕМЯНКИ?\n"
+ "Высокие алюминиевые профессиональные стремянки обладают выда...\n"
+ "КАК ВЫБРАТЬ СТРЕМЯНКУ ДЛЯ КВАРТИРЫ?\n"
+ "Ассортимент стремянок достаточно широк, они изготавливаются...\n"
+ "ОБЗОР АЛЮМИНИЕВОЙ СТРЕМЯНКИ ALUMET (АЛЮМЕТ) 4Х4 ТЛ4044\n"
+ "При выборе лестницы многие ищут универсальные варианты, кото...\n"
+ "КАК РАЗЛОЖИТЬ ЛЕСТНИЦУ ТРАНСФОРМЕР АЛЮМЕТ 4Х4 ТЛ4044: ВИДЕО\n"
+ "Для проведения наружных и внутренних работ потребуется шарни...\n"
+ "КАК ОТРЕМОНТИРОВАТЬ СТУПЕНЬКИ У СТРЕМЯНКИ?\n"
+ "Высокие алюминиевые профессиональные стремянки обладают выда...\n"
+ "КАК ВЫБРАТЬ СТРЕМЯНКУ ДЛЯ КВАРТИРЫ?\n"
+ "Ассортимент стремянок достаточно широк, они изготавливаются...\n"
+ "ОБЗОР АЛЮМИНИЕВОЙ СТРЕМЯНКИ ALUMET (АЛЮМЕТ) 4Х4 ТЛ4044\n"
+ "При выборе лестницы многие ищут универсальные варианты, кото...\n"
+ "КАК РАЗЛОЖИТЬ ЛЕСТНИЦУ ТРАНСФОРМЕР АЛЮМЕТ 4Х4 ТЛ4044: ВИДЕО\n"
+ "Для проведения наружных и внутренних работ потребуется шарни...\n\n"
+ "Все статьи\n\n"
+ "+7 499 347-57-07 | 01VVK@BK.RU\n\n"
+ "Москва, пос. Восточный, ул.Западная, дом 6, стр. 18\n\n"
+ " \n"
+ " \n\n"
+ "Информация\n\n"
+ "О магазине\n"
+ "Блог\n"
+ "Оплата\n"
+ "Прайсы\n"
+ "Производители\n"
+ "Оптом\n"
+ "Доставка\n"
+ "Контакты\n"
+ "Аренда\n"
+ "Карта сайта\n"
+ " \n\n"
+ "Каталог\n\n"
+ "Стремянки\n"
+ "Подставки\n"
+ "Подмости | Ящики и кейсы\n"
+ "Деревянные стремянки | Лестницы\n"
+ "Вышки туры\n"
+ "Аксессуары | Колеса и ролики\n"
+ "Шарнирные лестницы\n"
+ "Лестницы с платформой\n"
+ "Специальные лестницы\n"
+ " \n\n"
+ "К оплате принимаем\n\n\n"
+ " заказать звонок\n\n"
+ " \n\n"
+ " \n\n"
+ "Copyright © 2020 | Все права защищены\n\n"
+ "Отправьте нам сообщение\n"
+ "Отправьте нам сообщение\n"
+ "Здравствуйте.\n"
+ "У вас возникли вопросы? Мы с удовольствием ответим!\n"
+ "Бизнес-мессенджер \"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}