# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([\s\S]*?)(football)/\1boxing/gm;t' <<< "Here is football match.\n I want to replace football with something else \n that also consider to change footballA too"