use strict;
my $str = 'Here is football match.\\n I want to replace football with something else \\n that also consider to change footballA too';
my $regex = qr/([\s\S]*?)(football)/mp;
my $subst = '\\1boxing';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";