$re = '/([\s\S]*?)(football)/m';
$str = 'Here is football match.\\n I want to replace football with something else \\n that also consider to change footballA too';
$subst = "\1boxing";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;