// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([\s\S]*?)(football)").unwrap();
let string = "Here is football match.\\n I want to replace football with something else \\n that also consider to change footballA too";
let substitution = "\\1boxing";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}