import Foundation
let pattern = #"([\s\S]*?)(football)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Here is football match.\n I want to replace football with something else \n that also consider to change footballA too"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1boxing"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)