using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=(?:[^\d.\n]*[\d.]){2})(?:[^\n*]*\*){1,2}[^\n*]*$";
string input = @"1*2
1**2
*2.*
ab*
1*
1*2*.*";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}