package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\+?|0*|(972)?(.*)`)
var str = `0527691234
00527691234
527691234
00972527691234
972527691234
+972527691234
`
var substitution = "$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}