import re
regex = re.compile(r"\+?|0*|(972)?(.*)")
test_str = ("0527691234\n"
"00527691234\n"
"527691234\n"
"00972527691234\n"
"972527691234\n"
"+972527691234\n")
subst = "$2"
result = regex.sub(subst, test_str)
if result:
print(result)