# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\w*)<?>?\s*=(?=(?:[^"]|"[^"]*["])*$)//gm;t' <<< "import java.io.File;
import java.io.IOException;
import java.util.ArrayList;
import java.util.List;
private final String COMMENTS = \"test\";
private final String VARIABLE_NAME_REGEX=\"(\w*)<?>?\s*=(?=(?:[^\"]|\"[^\"]*[\"])*$)\";
String test=\"test\";
String test222;
String includeThisAlso ;
List <String> arr;
List <String> list=null;
"