import Foundation
let pattern = #"^\/(storage\/archive\/[0-9a-f-]{36}.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/storage/archive/ab7572d3-c697-4cfa-9b23-71b6f9c388d1
/public/storage/archive/ab7572d3-c697-4cfa-9b23-71b6f9c388d1
/storage/archive/not-hexadecimal-123456789abcdef01234
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)