$re = '/\(CVE-(?<CVE>[^\)]*)\)/';
$str = 'XXXXDxxxre xxxrability (CVE-201x-00xx) (severity = Low)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);