$re = '/^([0-9]{4})(\/|-)?(0[1-9]|1[012])(\/|-)?(0[1-9]|[12][0-9]|3[01])$/m';
$str = '13/10/2022
10/10/2022
13/10/22
10/10/22
13-10-2022
10-10-2022
13-10-22
10-10-22
131022
101022
13102022
10102022
20221013
20221010
2022-10-13
2022-10-10
2022/10/13
2022/10/10';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);