package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:dog(?:, |$))*(?:cat)?$`)
var str = `cat
dog, cat
dog, dog, cat
dog, dog, dog
dog, dog, dog, cat
dog, dog, dog, dog, cat
dog, dog, dog, dog, dog
dog, dog, dog, dog, dog, cat
dog, dog, dog, dog, dog, dog, dog, cat
dog, dog, dog, dog, dog, dog, dog, dog, dog
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}