package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\((-?\d+)\s*,\s*(-?\d+)\)`)
var str = `(1332, 5444)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}