import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(\\d*\\.?\\d+)\\s*(?:tab|cap|grag|past|sob|comp)";
final String string = " PRODUCTS\n"
+ "0 PULSAR AT 20 MG ORAL 30 TAB RECUB\n"
+ "1 LIPITOR 40 MG 1+1 ORAL 15 TAB\n"
+ "2 LOFTYL 150 MG ORAL 30 TAB\n"
+ "3 SOMAZINA 500 MG ORAL 10 COMP RECUB\n"
+ "4 LOFTYL 30 TAB 150 MG ORAL";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}