Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
r"
(?i)(\d*\.?\d+)\s*(?:tab|cap|grag|past|sob|comp)
"
gm
Input 1
1
New
PRODUCTS 0 PULSAR AT 20 MG ORAL 30 TAB RECUB 1 LIPITOR 40 MG 1+1 ORAL 15 TAB 2 LOFTYL 150 MG ORAL 30 TAB 3 SOMAZINA 500 MG ORAL 10 COMP RECUB 4 LOFTYL 30 TAB 150 MG ORAL