# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\G(?!\A)|")[^"\s]*\K(?:\s|"(*SKIP)(*F))/#/gm;t' <<< "good with spaces \"here all spaces sould be removed\" and here allso good
good with spaces \"here all spaces sould be removed\" and here allso good"