#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:\G(?!\A)|")[^"\s]*\K(?:\s|"(*SKIP)(*F))"
Local $sString = "good with spaces "here all spaces sould be removed" and here allso good" & @CRLF & _
"good with spaces "here all spaces sould be removed" and here allso good"
Local $sSubst = "#"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)