using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\G(?!\A)|"")[^""\s]*\K(?:\s|""(*SKIP)(*F))";
string substitution = @"#";
string input = @"good with spaces ""here all spaces sould be removed"" and here allso good
good with spaces ""here all spaces sould be removed"" and here allso good";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}