use strict;
my $str = 'good with spaces "here all spaces sould be removed" and here allso good
good with spaces "here all spaces sould be removed" and here allso good';
my $regex = qr/(?:\G(?!\A)|")[^"\s]*\K(?:\s|"(*SKIP)(*F))/mp;
my $subst = '#';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";