re = /(?:\G(?!\A)|")[^"\s]*\K(?:\s|"(*SKIP)(*F))/m
str = 'good with spaces "here all spaces sould be removed" and here allso good
good with spaces "here all spaces sould be removed" and here allso good'
subst = '#'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result