package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([бвгджзк][аяеэюуёоиы][бвгджзк].*)$`)
var str = `человек
время
дело
век
жизнь
день
рука
раз
работа
слово
место
лицо
друг
забор
выгода
морковь
дуга
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}