$re = '/^([бвгджзк][аяеэюуёоиы][бвгджзк].*)$/m';
$str = 'человек
время
дело
век
жизнь
день
рука
раз
работа
слово
место
лицо
друг
забор
выгода
морковь
дуга
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);