// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([бвгджзк][аяеэюуёоиы][бвгджзк].*)$").unwrap();
let string = "человек
время
де ло
век
жизнь
день
рука
раз
работа
слово
место
лицо
друг
забор
выгода
морковь
дуга
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}